Внезапно на ноуте пропал wifi

Вот прям на ходу. Только что был — и нету. Передёрнул аппаратный выключатель — фиг там, не коннектится. Перегрузил ноут — wlan0 вообще пропал. Хотя драйвер вроде загрузился, девайс нашёл, а сетевой интерфейс никак не появляется..

Jun 22 16:59:28 kernel: [ 16.139837] Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
Jun 22 16:59:28 kernel: [ 16.139840] Copyright(c) 2003-2011 Intel Corporation
Jun 22 16:59:28 kernel: [ 16.140003] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
Jun 22 16:59:28 kernel: [ 16.140005] iwlwifi 0000:03:00.0: pci_resource_base = ffffc9000065c000
Jun 22 16:59:28 kernel: [ 16.140007] iwlwifi 0000:03:00.0: HW Revision ID = 0x34
Jun 22 16:59:28 kernel: [ 16.140239] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
Jun 22 16:59:28 kernel: [ 16.140316] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
Jun 22 16:59:28 kernel: [ 16.156042] iwlwifi 0000:03:00.0: device EEPROM VER=0x715, CALIB=0x6
Jun 22 16:59:28 kernel: [ 16.156045] iwlwifi 0000:03:00.0: Device SKU: 0X1f0
Jun 22 16:59:28 kernel: [ 16.156047] iwlwifi 0000:03:00.0: Valid Tx ant: 0X3, Valid Rx ant: 0X3
Jun 22 16:59:28 kernel: [ 16.156076] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels

Мистика какая-то. И только при внимательном разглядывании kern.log обнаружилась истинная причина:

Jun 22 16:59:28 kernel: [ 16.302978] iwlwifi 0000:03:00.0: firmware: agent aborted loading iwlwifi-6000g2a-5.ucode (not found?)
Jun 22 16:59:28 kernel: [ 16.303167] iwlwifi 0000:03:00.0: no suitable firmware found!

Посмотрел в /lib/firmware, натурально там только iwlwifi-6000g2a-6.ucode есть. Попробовал сделать из него симлинк на -5, фокус не удался:

Jun 22 17:06:36 kernel: [ 449.756085] iwlwifi 0000:03:00.0: firmware: agent loaded iwlwifi-6000g2a-5.ucode into memory
Jun 22 17:06:36 kernel: [ 449.756091] iwlwifi 0000:03:00.0: Driver unable to support your firmware API. Driver supports v5, firmware is v6.
Jun 22 17:06:36 kernel: [ 449.756094] iwlwifi 0000:03:00.0: no suitable firmware found!

Экая фигня..
Ну, прицепил кабель, поставил firmware-iwlwifi, там нашёлся нужный iwlwifi-6000g2a-5.ucode, загрузился, wifi заработал.

Но один вопрос не даёт мне покоя: а как же оно до сих пор-то работало?!


You can read this post at LiveJournal.
This entry was posted in Uncategorized and tagged , , , . Bookmark the permalink.

Leave a Reply