nVidia и звук по HDMI. Возвращаясь к напечатанному

Мне тут сказали, что в последних снапшотах ALSA наконец-то приделали нормальную поддержку звука по HDMI для nVidia. Скачал исходники, собрал.

Не сказать, что звука совсем нет. Но устройств воспроизведения получилось четыре, и почему-то все mono:

$ amixer
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

Звук из всех четырёх в телевизоре слышится совершенно одинаково, причём независимо от состояния mute. Но чтобы он вообще появился, его надо первым делом проиграть через устройство номер 7 (aplay -D plughw:0,7 /oldroot/usr/share/sounds/alsa/Noise.wav). После этого он появляется и при проигрывании через остальные. А если этого не сделать, то будет тишина.

А самое обидное, что звук какой-то сильно звенящий, слушать невозможно.

Откатился на старую схему с аналоговым звуком и CustomEDID.

This entry was posted in Uncategorized and tagged , , . Bookmark the permalink.

Leave a Reply